Duplicate sales
Incident Report for Sync with Connex
Resolved
This incident has been resolved.
Posted May 24, 2022 - 09:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted May 23, 2022 - 14:54 EDT
This incident affected: Sync with Connex Desktop.