QuickBooks Online Update

Incident Report for Connex

Resolved

This incident has been resolved.
Posted May 19, 2026 - 13:30 EDT

Monitoring

We have updated our QuickBooks Online integration for all bronze, silver and gold users. The sync is running fine. Please open a ticket if there are any sync issues.
Posted May 18, 2026 - 13:13 EDT
This incident affected: Connex for QuickBooks - QuickBooks Online Users.