Site slowness causing sync failure or delay. We are aware and working on the issue it will be fixed asap 12/5/25

Incident Report for Connex

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 08:55 EST

Identified

Site slowness causing sync failure or delay. We are aware and working on the issue it will be fixed asap 12/5/25
Posted Dec 05, 2025 - 08:20 EST
This incident affected: Connex for QuickBooks - Desktop Users and Connex for QuickBooks - QuickBooks Online Users.