ShipStation Quantity Duplicates
Incident Report for Sync with Connex
Resolved
This incident has been resolved.
Posted Jan 23, 2023 - 17:43 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2023 - 15:48 EST
Investigating
We are currently investigating this issue.
Posted Jan 23, 2023 - 12:15 EST
This incident affected: Sync with Connex Desktop.