Connex Site Slowness

Incident Report for Connex

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 15:32 EDT

Investigating

We are investigating the issue
Posted Apr 28, 2026 - 13:12 EDT
This incident affected: Connex for QuickBooks - Desktop Users.