You have no items or one or more of your amounts is not associated with an item. Please enter an item.
Incident Report for Sync with Connex
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 10:51 EDT
Monitoring
Please try syncing after 10:30 am EST. We are implementing a bug fix now.
Posted Jul 19, 2021 - 10:15 EDT
This incident affected: Sync with Connex Desktop.